Acquia DAM Performance Issue
Incident Report for Acquia DAM
Postmortem

Overview

On August 10th, 2023, we received reports that some customers were seeing one of a number of "Bad Gateway" error messages when attempting to load pages in DAM. In some cases refreshing the page would temporarily solve the issue. After investigation we found an issue with an update to an internal service. We released a fix for this internal service to mitigate issues users were seeing, and engineers continued to monitor the state of the service until they had confirmed the errors had subsided. 

Root Cause

Multiple servers were generating an increased number of error messages. This meant that when attempting to load a page, if the request was handled by a server having issues, customers would see one of the error messages. Requests handled by other servers were not impacted.

What We're Doing?

To resolve the issue, we made multiple updates to our servers. In addition, we're making significant changes to the impacted service to reduce the frequency of this issue moving forward.

Posted Aug 15, 2023 - 09:28 CDT

Resolved
We have resolved the issue causing some customers to see unexpected error messages when using the DAM. Contact Customer Support for help on Acquia DAM Community if you continue to experience any ongoing issues.
Posted Aug 10, 2023 - 20:18 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 10, 2023 - 18:21 CDT
Identified
We have identified the issue causing some customers to see unexpected error messages when using the DAM, and we are working on a fix.
Posted Aug 10, 2023 - 17:27 CDT
Investigating
We are currently investigating an issue where some customers are seeing unexpected error messages when using the DAM. In most cases refreshing the page will resolve the issue.
Posted Aug 10, 2023 - 16:55 CDT
This incident affected: Assets & Templates.