Acquia DAM Availability Issue

Incident Report for Acquia DAM

Postmortem

Overview

On July 21, 2026, our engineering team was alerted that some DAM sites were inaccessible. The team quickly identified the problem and resolved the issue.

Root Cause

A large increase in system load in a short period of time caused degraded performance for some of our infrastructure.

What We're Doing

We mitigated the immediate issue and are working on further infrastructure improvements to reduce the possibility and impact of similar events in the future.

Posted Jul 24, 2026 - 12:53 CDT

Resolved

We've resolved the issue affecting the availability of some sites. Contact Customer Support for help on Acquia DAM Community if you continue to experience any ongoing issues.
Posted Jul 21, 2026 - 19:06 CDT

Monitoring

A fix has been implemented and we are monitoring to ensure stability.
Posted Jul 21, 2026 - 18:33 CDT

Identified

We’ve identified the issue affecting the availability of some sites and are actively working on resolving the issue.
Posted Jul 21, 2026 - 17:55 CDT

Investigating

We're aware of an issue affecting the availability of some sites and are actively investigating.
Posted Jul 21, 2026 - 17:12 CDT
This incident affected: Assets & Templates.