Acquia DAM Degraded Performance

Incident Report for Acquia DAM

Postmortem

Overview

On December 4th, 2025, the Acquia DAM API (V2) and the Assets application experienced elevated error rates. Specifically, this impacted API (V2) calls requesting download links. Users attempting to access some pages that served downloads, such as Asset Digest, may also have encountered errors.

Root Cause

A networking bug caused by a previous update.

In January 2025 a subtle networking bug was introduced to a download related service. The infrastructure configuration at the time prevented potential issues caused by the bug. In October 2025 infrastructure around the download related service was updated. While the improved infrastructure provided immediate benefits, such as increased stability, it also created the conditions for the bug to manifest.

What We're Doing?

The bug was identified and patched. We’ve improved alerting to catch issues like this faster and we’re working on improvements to further reduce the impact of similar issues.

Posted Jan 15, 2026 - 10:14 CST

Resolved

We've resolved the issue causing increased error rates in the API (v2) and within DAM. Contact Customer Support for help on Acquia DAM Community if you continue to experience any ongoing issues.
Posted Dec 04, 2025 - 08:47 CST

Monitoring

We've implemented a fix for the issue causing increased error rates in the API (v2) and within DAM, and we are monitoring to ensure stability.
Posted Dec 04, 2025 - 08:28 CST

Identified

We've identified the issue causing increased error rates for the API (v2) and within DAM.
Posted Dec 04, 2025 - 08:11 CST

Investigating

We're investigating increased error messages for the API (v2) and within DAM.
Posted Dec 04, 2025 - 08:02 CST
This incident affected: API (REST v2) and Assets & Templates.