Asset previews and download delays issue.
Incident Report for Widen Collective
Resolved
We’ve resolved the issue with previews and download delays. Contact support@widen.com if you continue to experience any ongoing issues.
Posted 5 months ago. May 29, 2019 - 17:53 CDT
Investigating
We're currently experiencing longer than usual processing times for some image formats, such as Camera RAW, PSD, and AI formats.
Posted 5 months ago. May 29, 2019 - 14:20 CDT
This incident affected: API (REST v2), Assets & Templates, Embed/Share Links, Portals, and Workflow.