Acquia DAM File Processing Degredation
Incident Report for Acquia DAM
Postmortem

Overview

On October 28th, 2024, our engineers were alerted to degraded file processing performance for some customers. They began investigating and soon found the root of the issue. After addressing the issue they began working through the backlog of impacted work.

Root Cause

Some processors encountered unusually large files which reduced the amount of available resources and processing capacity. This caused degraded file processing performance.

What We're Doing?

We replaced the impacted processors and we are working on improvements to ensure that unusually large files don't degrade processor performance.

Posted Oct 31, 2024 - 13:21 CDT

Resolved
We have completed processing the delayed work. Contact Customer Support for help on Acquia DAM Community if you continue to experience any ongoing issues.
Posted Oct 28, 2024 - 16:35 CDT
Update
We are continuing to monitor to ensure stability and we are still processing the delayed work.
Posted Oct 28, 2024 - 14:06 CDT
Monitoring
We've resolved the recent issue causing degraded file processing performance for some customers and new uploads are processing as expected. We are currently processing delayed work and are monitoring to ensure stability.
Posted Oct 28, 2024 - 10:56 CDT
Identified
We've identified the issue causing degraded file processing performance and we are working on a fix.
Posted Oct 28, 2024 - 10:23 CDT
Investigating
We're currently investigating an issue causing degraded file processing performance for some customers.
Posted Oct 28, 2024 - 09:55 CDT
This incident affected: Assets & Templates.