Degraded Portals Performance

Incident Report for Acquia DAM

Postmortem

Overview

On May 5th, 2026, our engineering team was alerted about degraded performance when loading Portals for some customers. The team identified the issue, deployed a fix, and the issue was resolved.

Root Cause

An infrastructure issue degraded Portals performance and caused an increase in the number of errors.

What We're Doing?

We've addressed the root cause and are working on additional changes to further improve Portals stability and performance. We are also improving our alerting to catch similar issues sooner.

Posted May 12, 2026 - 09:36 CDT

Resolved

We have resolved the issue causing degraded Portals performance for some customers. Contact Customer Support for help on Acquia DAM Community if you continue to experience any ongoing issues.
Posted May 05, 2026 - 18:40 CDT

Monitoring

A fix has been implemented for the issue causing degraded Portals performance and we're monitoring to ensure stability.
Posted May 05, 2026 - 18:04 CDT

Identified

We've identified the issue causing degraded Portals performance for some customers and we are working on a fix.
Posted May 05, 2026 - 17:34 CDT

Investigating

We are investigating an issue where some customers are encountering degraded performance when loading Portals.
Posted May 05, 2026 - 14:36 CDT
This incident affected: Portals.