Asset previews and download delays issue.
Incident Report for Widen Collective
Resolved
We’ve resolved the issue with previews and download delays. Contact support@widen.com if you continue to experience any ongoing issues.
Posted about 2 months ago. Aug 20, 2019 - 11:57 CDT
Investigating
We're currently experiencing longer than usual processing times for some image formats, such as Camera RAW, PSD, and AI formats.
Posted about 2 months ago. Aug 20, 2019 - 08:36 CDT
This incident affected: API (REST v2), Assets & Templates, Embed/Share Links, and Portals.