Acquia DAM Degraded Performance

Incident Report for Acquia DAM

Resolved

We have resolved the issue causing the global navigation bar to take longer to load than expected. Contact Customer Support for help on Acquia DAM Community if you continue to experience any ongoing issues.
Posted Apr 29, 2026 - 19:07 CDT

Monitoring

A fix has been implemented and we are monitoring to ensure stability.
Posted Apr 29, 2026 - 18:02 CDT

Identified

We have identified the issue causing the global navigation bar to take longer to load than expected, and we are working on a fix.
Posted Apr 29, 2026 - 17:11 CDT

Update

We are continuing to investigate an issue where the global navigation bar is taking longer to load than expected.
Posted Apr 29, 2026 - 16:00 CDT

Investigating

We are investigating an issue where the global navigation bar is taking longer to load than expected.
Posted Apr 29, 2026 - 10:17 CDT
This incident affected: Assets & Templates, Entries, Portals, and Workflow.